genivi-ipc@lists.genivi.org

Development list for inter process communication (IPC) related topics

View all threads

CommonAPI C++ SOME/IP in 10 mins

AC
Aananth C N
Thu, Apr 6, 2017 2:31 PM

HI,

I followed the instructions given in the page: https://at.projects.genivi.
org/wiki/pages/viewpage.action?pageId=5472320

I am able to generate images, but when I run I see differences in the logs
(between the page above and what I get as a log below).

Can someone provide me hints or pointers on how to debug this issue?

aananth@acn-m700:~/projects/framework-study/test-someip/build$ export
VSOMEIP_CONFIGURATION_FILE=../fidl/vsomeip.json
aananth@acn-m700:~/projects/framework-study/test-someip/build$
VSOMEIP_APPLICATION_NAME=service-sample ./HelloWorldService &
[1] 24601
aananth@acn-m700:~/projects/framework-study/test-someip/build$ 2017-04-06
19:46:32.003860 [info] Parsed vsomeip configuration in 0ms
2017-04-06 19:46:32.003941 [info] Default configuration module loaded.
2017-04-06 19:46:32.003953 [info] Initializing vsomeip application
"service-sample".
2017-04-06 19:46:32.004009 [info] SOME/IP client identifier configured.
Using 0013 (was: 0000)
2017-04-06 19:46:32.004020 [info] No routing manager configured. Using
auto-configuration.
2017-04-06 19:46:32.004027 [info] Instantiating routing manager [Proxy].
2017-04-06 19:46:32.004050 [info] Client [13] is connecting to [0] at
/tmp/vsomeip-0
2017-04-06 19:46:32.004104 [info] Listening at /tmp/vsomeip-13
2017-04-06 19:46:32.004115 [info] Application(service-sample, 13) is
initialized (11, 100).
2017-04-06 19:46:32.004300 [info] Starting vsomeip application
"service-sample" using 2 threads
Successfully Registered Service!
Waiting for calls... (Abort with CTRL+C)

aananth@acn-m700:~/projects/framework-study/test-someip/build$
VSOMEIP_APPLICATION_NAME=client-sample ./HelloWorldClient
2017-04-06 19:46:40.811473 [info] Parsed vsomeip configuration in 0ms
2017-04-06 19:46:40.811555 [info] Default configuration module loaded.
2017-04-06 19:46:40.811566 [info] Initializing vsomeip application
"client-sample".
2017-04-06 19:46:40.811620 [info] SOME/IP client identifier configured.
Using 0014 (was: 0000)
2017-04-06 19:46:40.811631 [info] No routing manager configured. Using
auto-configuration.
2017-04-06 19:46:40.811637 [info] Instantiating routing manager [Proxy].
2017-04-06 19:46:40.811659 [info] Client [14] is connecting to [0] at
/tmp/vsomeip-0
2017-04-06 19:46:40.811716 [info] Listening at /tmp/vsomeip-14
2017-04-06 19:46:40.811727 [info] Application(client-sample, 14) is
initialized (11, 100).
2017-04-06 19:46:40.811909 [info] Starting vsomeip application
"client-sample" using 2 threads

HI, I followed the instructions given in the page: https://at.projects.genivi. org/wiki/pages/viewpage.action?pageId=5472320 I am able to generate images, but when I run I see differences in the logs (between the page above and what I get as a log below). Can someone provide me hints or pointers on how to debug this issue? aananth@acn-m700:~/projects/framework-study/test-someip/build$ export VSOMEIP_CONFIGURATION_FILE=../fidl/vsomeip.json aananth@acn-m700:~/projects/framework-study/test-someip/build$ VSOMEIP_APPLICATION_NAME=service-sample ./HelloWorldService & [1] 24601 aananth@acn-m700:~/projects/framework-study/test-someip/build$ 2017-04-06 19:46:32.003860 [info] Parsed vsomeip configuration in 0ms 2017-04-06 19:46:32.003941 [info] Default configuration module loaded. 2017-04-06 19:46:32.003953 [info] Initializing vsomeip application "service-sample". 2017-04-06 19:46:32.004009 [info] SOME/IP client identifier configured. Using 0013 (was: 0000) 2017-04-06 19:46:32.004020 [info] No routing manager configured. Using auto-configuration. 2017-04-06 19:46:32.004027 [info] Instantiating routing manager [Proxy]. 2017-04-06 19:46:32.004050 [info] Client [13] is connecting to [0] at /tmp/vsomeip-0 2017-04-06 19:46:32.004104 [info] Listening at /tmp/vsomeip-13 2017-04-06 19:46:32.004115 [info] Application(service-sample, 13) is initialized (11, 100). 2017-04-06 19:46:32.004300 [info] Starting vsomeip application "service-sample" using 2 threads Successfully Registered Service! Waiting for calls... (Abort with CTRL+C) aananth@acn-m700:~/projects/framework-study/test-someip/build$ VSOMEIP_APPLICATION_NAME=client-sample ./HelloWorldClient 2017-04-06 19:46:40.811473 [info] Parsed vsomeip configuration in 0ms 2017-04-06 19:46:40.811555 [info] Default configuration module loaded. 2017-04-06 19:46:40.811566 [info] Initializing vsomeip application "client-sample". 2017-04-06 19:46:40.811620 [info] SOME/IP client identifier configured. Using 0014 (was: 0000) 2017-04-06 19:46:40.811631 [info] No routing manager configured. Using auto-configuration. 2017-04-06 19:46:40.811637 [info] Instantiating routing manager [Proxy]. 2017-04-06 19:46:40.811659 [info] Client [14] is connecting to [0] at /tmp/vsomeip-0 2017-04-06 19:46:40.811716 [info] Listening at /tmp/vsomeip-14 2017-04-06 19:46:40.811727 [info] Application(client-sample, 14) is initialized (11, 100). 2017-04-06 19:46:40.811909 [info] Starting vsomeip application "client-sample" using 2 threads