<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">Dear Colleagues,<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Thank you for the tips. It seems that there is some lexical order to the parser.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">For example, this will generate a syntax error:<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">define org.genivi.commonapi.someip.deployment for interface commonapi.HelloWorld {<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New""><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">     SomeIpServiceID = 4660<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New""><o:p> </o:p></span></p>
<p class="MsoNormal" style="text-indent:36.0pt"><span style="font-family:"Courier New"">method sayHello {<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpMethodID = 3300<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">     }  <o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">          <o:p></o:p></span></p>
<p class="MsoNormal" style="text-indent:36.0pt"><span style="font-family:"Courier New"">attribute Bob {<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpGetterID = 100<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpSetterID = 200<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">          SomeIpNotifierID = 33000       
<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpEventGroups = { 33002 }<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">      }<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">}<o:p></o:p></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">But the following will not.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">define org.genivi.commonapi.someip.deployment for interface commonapi.HelloWorld {<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">     SomeIpServiceID = 4660<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">    <o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">     attribute Bob {<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpGetterID = 100<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpSetterID = 200<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">        SomeIpNotifierID = 33000       
<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpEventGroups = { 33002 }<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">    }<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New""><o:p> </o:p></span></p>
<p class="MsoNormal" style="text-indent:36.0pt"><span style="font-family:"Courier New"">method sayHello {<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">           SomeIpMethodID = 3300<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">     }  <o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family:"Courier New"">}<o:p></o:p></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">This was tested on the SOMEIP generator 3.1.11.0<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">With that solved, I managed to generate the code, and now the service is running on the Raspberry Pi 3, and I am able to see the SOME/IP packets. If I run the client application locally on the RPi, it can connect to the service too.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">My current problem is that I need the client application on a remote device, but I had no success. In the virtualbox GDP I can capture the offered network packets with wireshark (so the routing is properly configured for the broadcast packets),
 but the client remains in a listen state.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">My best guess is that the .json configuration file is not proper, so I would like to ask for your help, how this file should look like. It is not clear to me, for example, what IP should be set on the client side.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I attach my current file. <o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Thank you for your answer in advance.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="font-size:10.0pt;font-family:"Arial",sans-serif;color:black">▄dv÷zlettel / Best regards
<br>
<br>
<b>Bence Kocsis<br>
AE/EEC4<br>
</b></span><span style="font-size:8.0pt;font-family:"Arial",sans-serif;color:black"><br>
<br>
</span><o:p></o:p></p>
</div>
</body>
</html>