Qt5 Serial Bus error on Ubuntu 16 and 17 versions

Pradeep Ummiti pradeepummiti at yahoo.com
Tue Aug 1 16:59:39 EDT 2017


Hi Daniel,
Thank you for the reply. I was able to compile and run the CANdevStudio project on my Linux machine.
Currently, I'm running the code using the steps mentioned in Virtual CAN interface section of the link below.CANdevStudio Build instructions - Projects - Confluence

This is my first encounter to Qt, and I want to find out how can I change the code so that this can be used with actual CAN channels in future. We have a Vehicle Interface HW, which supports the CAN channels, and on the Application processor, we are planning to use CANdevStudio project or other tool which can be used to monitor CAN data.
We will be running SocketCAN daemon process on the application processor.
Any help/inputs on this are much appreciated. I want to know the files that I need to focus on when I'm trying to use it in a real-time scenario. Also, can we select multiple CAN channels? 
Thanks & Regards,Pradeep Ummiti

On Tuesday, August 1, 2017, 12:17:48 PM EDT, Kozar, Daniel <daniel.kozar at mobica.com> wrote:

Hi Pradeep.Unfortunately, the Qt packages provided in the standard Ubuntu/Debian repositories don't include Qt5SerialBus at all. The easiest solution is to simply grab the whole Qt package from http://download.qt.io .
As to why you're unable to compile Qt5SerialBus yourself, it's because it is meant to be compiled as a part of Qt itself and it requires its internal ("private") headers, which are not part of the library's interface and therefore must not be shipped with any packages.
Kind regards,Daniel
On 1 August 2017 at 17:52, Pradeep Ummiti via genivi-projects <genivi-projects at lists.genivi.org> wrote:

Hi,
I'm trying to compile CANdevStudio project on Ubuntu machine. I'm following the steps mentioned in 
https://at.projects.genivi. org/wiki/display/PROJ/ CANdevStudio+Build+ instructions

I'm having some trouble at step #6, which is the "cmake .." command. When I execute the command, and I initially get an error related to  "Qt5CoreConfig.cmake", which I'm able to resolve by installing "qtbase5-dev" package. Then, I error related to "Qt5SerialBusConfig.cmake". Below is the screenshot of the same.


On looking more into this, I found out that I have to install Serial Bus package. The Qt version which I have is 5.7.1. I installed Qt Serial Bus package as per the instructions provided in the below link.https://www.ics.com/blog/ whats-new-qt-560-qtserialbus

Now, I get the message saying that some of the modules are missing. 


I believe it is looking for Serial Port module. So I tried to install Serial Port module as per the instructions in the link below.
Qt Serial Port - Qt Wiki

I try to follow the steps mentioned in the below screenshot, but I get compilation errors when I execute "make" command.



I'm not sure how to solve the "Qt5SerialBusConfig.cmake" error.
Any guidance is much appreciated. I am using a VirtualBox, and I tried using Ubuntu 16.04 and Ubuntu 17.04, but the same error appears on both the versions.
Looking forward for your help on this.
Thanks & Regards,Pradeep Ummiti
______________________________ _________________
genivi-projects mailing list
genivi-projects at lists.genivi. org
https://lists.genivi.org/ mailman/listinfo/genivi- projects



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.genivi.org/pipermail/genivi-projects_lists.genivi.org/attachments/20170801/60f853e6/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1501602467479blob.jpg
Type: image/png
Size: 59613 bytes
Desc: not available
URL: <http://lists.genivi.org/pipermail/genivi-projects_lists.genivi.org/attachments/20170801/60f853e6/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1501602552267blob.jpg
Type: image/png
Size: 602413 bytes
Desc: not available
URL: <http://lists.genivi.org/pipermail/genivi-projects_lists.genivi.org/attachments/20170801/60f853e6/attachment-0001.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1501600942147blob.jpg
Type: image/png
Size: 142105 bytes
Desc: not available
URL: <http://lists.genivi.org/pipermail/genivi-projects_lists.genivi.org/attachments/20170801/60f853e6/attachment-0002.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1501602085525blob.jpg
Type: image/png
Size: 141267 bytes
Desc: not available
URL: <http://lists.genivi.org/pipermail/genivi-projects_lists.genivi.org/attachments/20170801/60f853e6/attachment-0003.jpg>


More information about the genivi-projects mailing list