Api backward/forward compatibility

Ucan, Emre (ADITG/ESB) eucan at de.adit-jv.com
Tue Sep 18 02:40:07 EDT 2018


Hi Shi,

I checked the diff between 1.13 and 1.10.90. Your old app should work. We did not remove any APIs.

But we never tested API compatibility between versions. Therefore, I cannot guarantee.

Best regards

Emre Ucan
Engineering Software Base (ADITG/ESB)

Tel. +49 5121 49 6937
> -----Original Message-----
> From: genivi-ivi-layer-management <genivi-ivi-layer-management-
> bounces at lists.genivi.org> On Behalf Of Shi Yan
> Sent: Donnerstag, 13. September 2018 19:55
> To: genivi-ivi-layer-management at lists.genivi.org
> Subject: Api backward/forward compatibility
> 
> 
> 
> Hello mailing list,
> 
> I have a question regarding api backward compatibility.
> 
> We have an old app which was linked against  libilmCommon.so.1.10.90  and
> libilmClient.so.1.10.90, then we updated the linux system. now both libraries
> are upgraded to 1.13.0.
> 
> I want to know what the spec says regarding api backward/forward
> compatibility, because we have not found anything in the official document.
> 
> Should we expect the old app to still work with the newer libraries?
> 
> Thanks,
> 
> Shi
> 
> -----------------------------------------------------------------------------------
> This email message is for the sole use of the intended recipient(s) and may
> contain
> confidential information.  Any unauthorized review, use, disclosure or
> distribution
> is prohibited.  If you are not the intended recipient, please contact the
> sender by
> reply email and destroy all copies of the original message.
> -----------------------------------------------------------------------------------
> _______________________________________________
> genivi-ivi-layer-management mailing list
> genivi-ivi-layer-management at lists.genivi.org
> https://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management


More information about the genivi-ivi-layer-management mailing list