Same ilm surface on multiple layer support

Ucan, Emre (ADITG/ESB) eucan at de.adit-jv.com
Tue Apr 10 10:13:21 EDT 2018


Hi Vikas,

This patch “5e8d55da698e58”  enabled the feature. It is part of weston 1.12 release.

Best regards

Emre Ucan
Engineering Software Base (ADITG/ESB)

Tel. +49 5121 49 6937
From: wayland-devel [mailto:wayland-devel-bounces at lists.freedesktop.org] On Behalf Of Vikas Patil
Sent: Dienstag, 10. April 2018 14:58
To: genivi-ivi-layer-management at lists.genivi.org; Mizuno, Wataru (ADITJ/SWG); wayland mailing list
Subject: Same ilm surface on multiple layer support

+Subject
Dear All,
We are facing issue when we are trying to add same surface to multiple layers. When we try to attach surface to another layer, it is getting detached from the earlier layer.
We are using wayland/weston/wayland-ivi-extension 1.11.0 with drm-backend on TI's Soc.
Could anyone know if this is the limitation of ILM 1.11.0 ? Is this fixed in newer version and can it be ported to 1.11.0 ? or Is there any other way to show same surface on multiple layers?
I see it was the limitation with wayland-ivi-extesnion 1.9.0 as below [1].

"Currently 1 layer can be only on 1 screen, and 1 surface can be only on 1 layer,
 we are planning to relax this limitation And allow 1 surface to be on many layers but we would need to break the ABI and change the
ivi-controller protocol."
[1] https://lists.genivi.org/pipermail/genivi-ivi-layer-management/2016-October/005416.html

Thanking you in advance.

Best Regards,
Vikash


More information about the genivi-ivi-layer-management mailing list