ilm_common.h not found (meta-ivi 13.0 / pyro)

Gunnar Andersson gunnar.genivi at gmail.com
Wed Sep 6 05:32:54 EDT 2017


On Wed, 2017-09-06 at 08:09 +0000, Friedrich, Eugen (ADITG/ESB) wrote:
> Hi Gunnar,
> Sorry for late response,

No worries - it helped to CC you :-)

> 
> No we did not move it, it should be there. 
> My guess would be the dependency is missing in the new build.

It might be that simple...  In fact I don't see an explicit dependency from
this recipe - wayland-ivi-extension is only required by the GDP platform
itself.

> Could you check if the wayland-ivi-extension was build?

...but as far as I could see, all the steps for wayland-ivi-extension
including do_install ran before the problem occured.

Is it really correct to include "ilm/ilm_common.h" rather than just
"ilm_common.h" (or rather <ilm_common.h>)?

> We also added the *.pc files which are exported now maybe this leads to
> some issue in cross_compilation.

Oscar is working on another ticket blocked by this one so he might take over
this ticket or make some investigations into this, we'll see.

Thanks
- Gunnar

> 
> Best regards
> 
> Eugen Friedrich
> Software Group I (ADITG/SW1)
> 
> Tel. +49 5121 49 6921
> 
> > -----Original Message-----
> > From: Gunnar Andersson [mailto:gunnar.genivi at gmail.com]
> > Sent: Mittwoch, 6. September 2017 10:07
> > To: genivi-ivi-layer-management at lists.genivi.org; Friedrich, Eugen
> > (ADITG/ESB); Ucan, Emre (ADITG/ESB)
> > Cc: Jacobo Aragunde Pérez; Oscar Andreasson (Luxoft/Pelagicore)
> > Subject: Re: ilm_common.h not found (meta-ivi 13.0 / pyro)
> > 
> > 
> > Anyone have a clue?
> > 
> > 1. Did you move the installation location of ilm_commmon.h between 1.11
> > and
> > 1.13 or what could possibly be the issue?
> > (and)
> > 2. Is ilm_common.h considered an exported interface that is supposed to
> > be
> > used?
> > 
> > Thanks for your support
> > - Gunnar
> > 
> > 
> > On Mon, 2017-09-04 at 13:49 +0200, Gunnar Andersson wrote:
> > > Hello
> > > 
> > > The Chromium feature branch of GDP started failing when we ported it
> > > to
> > > Yocto pyro branch and meta-ivi.  It looks like an easy error so I'm
> > > reaching
> > > out to the mailing list if you have any immediate ideas.
> > > 
> > > It is simply a header file that is no longer found, so it should be
> > > trivial
> > > but you will know best.
> > > 
> > > 
> > > ERROR:
> > > 
> > > 12:24:19.235 | ../../ozone/wayland/shell/ivi_shell_surface.cc:14:28:
> > > fatal
> > > error: ilm/ilm_common.h: No such file or directory:
> > > 
> > > Full build log: [2]
> > > 
> > > 
> > > VERSIONS:
> > > 
> > > Old version / master:
> > > meta-ivi/ ... / wayland-ivi-extension_1.11.1.bb
> > > 
> > > pyro: (failing)
> > > meta-ivi/ ... / wayland-ivi-extension_1.13.0.bb
> > > 
> > > 
> > > I am reaching out because I imagine one of the layer manager folks
> > > might
> > > immediately know what this is.  Maybe you moved some header file
> > 
> > between
> > > the
> > > versions?  Maybe ilm_common.h is not supposed to be used from outside?
> > > 
> > > If you have any ideas, please let us know in the mail thread, or
> > > directly
> > > on
> > > the ticket [1]
> > > 
> > > Thanks
> > > - Gunnar
> > > 
> > > 
> > > [1] https://at.projects.genivi.org/jira/browse/GDP-728
> > > [2] https://go.genivi.org/go/files/Release-minnowboard-
> > 
> > chromium/6/build/1/
> > > init_and_bitbake/cruise-output/console.log
> > > 
> 
> _______________________________________________
> genivi-ivi-layer-management mailing list
> genivi-ivi-layer-management at lists.genivi.org
> https://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management




More information about the genivi-ivi-layer-management mailing list