ilm_common.h not found (meta-ivi 13.0 / pyro)

Gunnar Andersson gunnar.genivi at gmail.com
Wed Sep 6 04:06:26 EDT 2017


Anyone have a clue?   

1. Did you move the installation location of ilm_commmon.h between 1.11 and
1.13 or what could possibly be the issue?
(and)
2. Is ilm_common.h considered an exported interface that is supposed to be
used?

Thanks for your support
- Gunnar


On Mon, 2017-09-04 at 13:49 +0200, Gunnar Andersson wrote:
> Hello
> 
> The Chromium feature branch of GDP started failing when we ported it to
> Yocto pyro branch and meta-ivi.  It looks like an easy error so I'm
> reaching
> out to the mailing list if you have any immediate ideas.  
> 
> It is simply a header file that is no longer found, so it should be
> trivial
> but you will know best.
> 
> 
> ERROR:
> 
> 12:24:19.235 | ../../ozone/wayland/shell/ivi_shell_surface.cc:14:28: fatal
> error: ilm/ilm_common.h: No such file or directory:
> 
> Full build log: [2]
> 
> 
> VERSIONS:
> 
> Old version / master:
> meta-ivi/ ... / wayland-ivi-extension_1.11.1.bb
> 
> pyro: (failing)
> meta-ivi/ ... / wayland-ivi-extension_1.13.0.bb
> 
> 
> I am reaching out because I imagine one of the layer manager folks might
> immediately know what this is.  Maybe you moved some header file between
> the
> versions?  Maybe ilm_common.h is not supposed to be used from outside?
> 
> If you have any ideas, please let us know in the mail thread, or directly
> on
> the ticket [1]
> 
> Thanks
> - Gunnar
> 
> 
> [1] https://at.projects.genivi.org/jira/browse/GDP-728
> [2] https://go.genivi.org/go/files/Release-minnowboard-chromium/6/build/1/
> init_and_bitbake/cruise-output/console.log
> 




More information about the genivi-ivi-layer-management mailing list