screenshot of layer do not work!

Vikas Patil vikasmpatil at gmail.com
Tue Mar 14 04:05:28 EDT 2017


Thanks for your comment Emre Ucan. I think it is helpful API, Is there any
particular reason deprecating it?
Is there any other way I can take screen shot of layer, surface , screen?

Thanks & Regards,
Vikash

On Tue, Mar 14, 2017 at 1:26 PM, Ucan, Emre (ADITG/SW1) <
eucan at de.adit-jv.com> wrote:

> Hi Vikas,
>
> We are not planning to fix it. We will make the API deprecated.
>
> Best regards
>
> Emre Ucan
> Software Group I (ADITG/SW1)
>
> Tel. +49 5121 49 6937
>
> > -----Original Message-----
> > From: genivi-ivi-layer-management [mailto:genivi-ivi-layer-management-
> > bounces at lists.genivi.org] On Behalf Of Vikas Patil
> > Sent: Dienstag, 14. März 2017 06:43
> > To: genivi-ivi-layer-management at lists.genivi.org
> > Subject: screenshot of layer do not work!
> >
> > Dear All,
> >
> > I could verify the screen shot dump using the screen and surface but not
> > with layers. So following command do not work but other two works. I
> think
> > this is because controller_layer_screenshot() in ivi-controller.c is
> > missing implementation. Is there any patch available? or Is this planned?
> >
> > Any inputs on make it working?
> >
> > Line 732,
> > https://github.com/GENIVI/wayland-ivi-extension/blob/master/weston-ivi-
> > shell/src/ivi-controller.c
> >
> >
> > Do not work:
> > LayerManagerControl dump layer 1000 to /home/root/layer_1000.bmp
> >
> > Works:
> > LayerManagerControl dump screen 0 to /home/root/hmi_screen.bmp
> > LayerManagerControl dump surface 10 to /home/root/surface_10.bmp
> >
> >
> > Regards,
> > Vikash
> > _______________________________________________
> > genivi-ivi-layer-management mailing list
> > genivi-ivi-layer-management at lists.genivi.org
> > http://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management
>



More information about the genivi-ivi-layer-management mailing list