Please help me to get ilm_SUCCESS on ilm_init()

Ucan, Emre (ADITG/SW1) eucan at de.adit-jv.com
Mon Mar 6 05:43:48 EST 2017


Hi,

You are loading hmi-controller. You have to load ivi-controller.so

Best regards

Emre Ucan
Software Group I (ADITG/SW1)

Tel. +49 5121 49 6937
From: mukesh singh [mailto:hellopinkusingh at gmail.com]
Sent: Montag, 6. März 2017 11:43
To: Ucan, Emre (ADITG/SW1)
Cc: genivi-ivi-layer-management at lists.genivi.org
Subject: Re: Please help me to get ilm_SUCCESS on ilm_init()

Hi Emre,
Thanks for your input.
I modified the weston.ini file to start with ivi-shell.  But result is same.
[15:57:16.066] Loading module '/home/msingh/install/lib/weston/ivi-shell.so'
[15:57:16.066] launching '/home/msingh/install/libexec/weston-keyboard'
[15:57:16.066] Loading module '/home/msingh/install/lib/weston/hmi-controller.so'
[15:57:16.066] launching '/home/msingh/Desktop/Ocland/2ndMarch/wayland-ivi-extension/weston/weston-ivi-shell-user-interface'



Here is the LOG:

[1615065.529] -> wl_display at 1.get_registry(new<mailto:wl_display at 1.get_registry(new> id wl_registry at 2)

[1615065.608] -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)

[1615065.798] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>

[1615065.825] wl_registry at 2.global(1<mailto:wl_registry at 2.global(1>, "wl_compositor", 4)

[1615065.846] wl_registry at 2.global(2<mailto:wl_registry at 2.global(2>, "wl_subcompositor", 1)

[1615065.886] wl_registry at 2.global(3<mailto:wl_registry at 2.global(3>, "wp_viewporter", 1)

[1615065.911] wl_registry at 2.global(4<mailto:wl_registry at 2.global(4>, "wp_presentation", 1)

[1615065.940] wl_registry at 2.global(5<mailto:wl_registry at 2.global(5>, "zwp_relative_pointer_manager_v1", 1)

[1615065.979] wl_registry at 2.global(6<mailto:wl_registry at 2.global(6>, "zwp_pointer_constraints_v1", 1)

[1615066.020] wl_registry at 2.global(7<mailto:wl_registry at 2.global(7>, "wl_data_device_manager", 3)

[1615066.053] wl_registry at 2.global(8<mailto:wl_registry at 2.global(8>, "wl_shm", 1)

[1615066.089] wl_registry at 2.global(9<mailto:wl_registry at 2.global(9>, "wl_drm", 2)

[1615066.131] wl_registry at 2.global(10<mailto:wl_registry at 2.global(10>, "wl_seat", 5)

[1615066.165] wl_registry at 2.global(11<mailto:wl_registry at 2.global(11>, "zwp_linux_dmabuf_v1", 1)

[1615066.199] wl_registry at 2.global(12<mailto:wl_registry at 2.global(12>, "wl_output", 3)

[1615066.236] -> wl_registry at 2.bind(12<mailto:wl_registry at 2.bind(12>, "wl_output", 1, new id [unknown]@4)

[1615066.293] wl_registry at 2.global(13<mailto:wl_registry at 2.global(13>, "zwp_input_panel_v1", 1)

[1615066.324] wl_registry at 2.global(14<mailto:wl_registry at 2.global(14>, "zwp_input_method_v1", 1)

[1615066.355] wl_registry at 2.global(15<mailto:wl_registry at 2.global(15>, "zwp_text_input_manager_v1", 1)

[1615066.384] wl_registry at 2.global(16<mailto:wl_registry at 2.global(16>, "ivi_application", 1)

[1615066.411] wl_registry at 2.global(17<mailto:wl_registry at 2.global(17>, "ivi_hmi_controller", 1)

[1615066.446] wl_callback at 3.done(157)<mailto:wl_callback at 3.done(157)>

[1615066.472] -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)

[1615066.591] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>

[1615066.612] wl_output at 4.geometry(0<mailto:wl_output at 4.geometry(0>, 0, 270, 158, 0, "weston-X11", "none", 0)

[1615066.693] wl_output at 4.mode(3<mailto:wl_output at 4.mode(3>, 1024, 600, 60000)

[1615066.753] wl_callback at 3.done(157)<mailto:wl_callback at 3.done(157)>

[1615066.777] -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)

[1615066.853] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>

[1615066.877] wl_callback at 3.done(157)<mailto:wl_callback at 3.done(157)>

ivi_controller not available

[Warning] The ilm_control_context is already destroyed

[1615066.920] -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)

[1615066.983] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>

[1615066.999] wl_callback at 3.done(157)<mailto:wl_callback at 3.done(157)>




Regards,
Mukesh

On Mon, Mar 6, 2017 at 1:21 PM, Ucan, Emre (ADITG/SW1) <eucan at de.adit-jv.com<mailto:eucan at de.adit-jv.com>> wrote:
Hi,

Ilm_init fails because weston is started with desktop shell and not ivi-shell.

You have to modify weston.ini file to enable ivi-shell:

[core]
shell=ivi-shell.so

[ivi-shell]
ivi-module=ivi-controller.so

Best regards

Emre Ucan
Software Group I (ADITG/SW1)

Tel. +49 5121 49 6937
> -----Original Message-----
> From: mukesh singh [mailto:hellopinkusingh at gmail.com<mailto:hellopinkusingh at gmail.com>]
> Sent: Samstag, 4. März 2017 16:26
> To: Ucan, Emre (ADITG/SW1)
> Cc: genivi-ivi-layer-management at lists.genivi.org<mailto:genivi-ivi-layer-management at lists.genivi.org>
> Subject: Re: Please help me to get ilm_SUCCESS on ilm_init()
>
> Hi All,
> I am now running weston on ubuntu without any error.
> But still ilm_init() is failing.
> Enabled WAYLAND_DEBUG and got the below log.
>
> [658557.526]  -> wl_display at 1.get_registry(new<mailto:wl_display at 1.get_registry(new> id wl_registry at 2)
> [658557.599]  -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)
> [658557.800] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>
> [658557.830] wl_registry at 2.global(1<mailto:wl_registry at 2.global(1>, "wl_compositor", 4)
> [658557.870] wl_registry at 2.global(2<mailto:wl_registry at 2.global(2>, "wl_subcompositor", 1)
> [658557.908] wl_registry at 2.global(3<mailto:wl_registry at 2.global(3>, "wp_viewporter", 1)
> [658557.939] wl_registry at 2.global(4<mailto:wl_registry at 2.global(4>, "wp_presentation", 1)
> [658557.969] wl_registry at 2.global(5<mailto:wl_registry at 2.global(5>, "zwp_relative_pointer_manager_v1",
> 1)
> [658558.004] wl_registry at 2.global(6<mailto:wl_registry at 2.global(6>, "zwp_pointer_constraints_v1", 1)
> [658558.038] wl_registry at 2.global(7<mailto:wl_registry at 2.global(7>, "wl_data_device_manager", 3)
> [658558.071] wl_registry at 2.global(8<mailto:wl_registry at 2.global(8>, "wl_shm", 1)
> [658558.105] wl_registry at 2.global(9<mailto:wl_registry at 2.global(9>, "wl_drm", 2)
> [658558.135] wl_registry at 2.global(10<mailto:wl_registry at 2.global(10>, "wl_seat", 5)
> [658558.166] wl_registry at 2.global(11<mailto:wl_registry at 2.global(11>, "zwp_linux_dmabuf_v1", 1)
> [658558.201] wl_registry at 2.global(12<mailto:wl_registry at 2.global(12>, "wl_output", 3)
> [658558.244]  -> wl_registry at 2.bind(12<mailto:wl_registry at 2.bind(12>, "wl_output", 1, new id
> [unknown]@4)
> [658558.289] wl_registry at 2.global(13<mailto:wl_registry at 2.global(13>, "zwp_input_panel_v1", 1)
> [658558.320] wl_registry at 2.global(14<mailto:wl_registry at 2.global(14>, "zwp_input_method_v1", 1)
> [658558.352] wl_registry at 2.global(15<mailto:wl_registry at 2.global(15>, "zwp_text_input_manager_v1", 1)
> [658558.431] wl_registry at 2.global(16<mailto:wl_registry at 2.global(16>, "zxdg_shell_v6", 1)
> [658558.450] wl_registry at 2.global(17<mailto:wl_registry at 2.global(17>, "xdg_shell", 1)
> [658558.493] wl_registry at 2.global(18<mailto:wl_registry at 2.global(18>, "wl_shell", 1)
> [658558.531] wl_registry at 2.global(19<mailto:wl_registry at 2.global(19>, "weston_desktop_shell", 1)
> [658558.552] wl_registry at 2.global(20<mailto:wl_registry at 2.global(20>, "weston_screenshooter", 1)
> [658558.576] wl_callback at 3.done(752)<mailto:wl_callback at 3.done(752)>
> [658558.596]  -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)
> [658558.702] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>
> [658558.727] wl_output at 4.geometry(0<mailto:wl_output at 4.geometry(0>, 0, 270, 158, 0, "weston-X11",
> "none", 0)
> [658558.807] wl_output at 4.mode(3<mailto:wl_output at 4.mode(3>, 1024, 600, 60000)
> [658558.857] wl_callback at 3.done(752)<mailto:wl_callback at 3.done(752)>
> [658558.879]  -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)
> [658558.958] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>
> [658558.979] wl_callback at 3.done(752)<mailto:wl_callback at 3.done(752)>
> ivi_controller not available
> [Warning] The ilm_control_context is already destroyed
> [658559.020]  -> wl_display at 1.sync(new<mailto:wl_display at 1.sync(new> id wl_callback at 3)
> [658559.099] wl_display at 1.delete_id(3)<mailto:wl_display at 1.delete_id(3)>
> [658559.120] wl_callback at 3.done(752)<mailto:wl_callback at 3.done(752)>
>
>
> Regards,
> Mukesh
>
> On Mon, Feb 27, 2017 at 1:30 PM, Ucan, Emre (ADITG/SW1) <eucan at de.adit-
<mailto:eucan at de.adit-%0b>> jv.com<http://jv.com>> wrote:
>
>
>       Hi,
>
>       Your problem is nothing to do with wayland-ivi-extensions.
>
>       Weston cannot find the correct gpu driver. Therefore, it fails to start.
>
>       Best regards
>
>       Emre Ucan
>       Software Group I (ADITG/SW1)
>
>       Tel. +49 5121 49 6937
>       > -----Original Message-----
>       > From: genivi-ivi-layer-management [mailto:genivi-ivi-layer-<mailto:genivi-ivi-layer->
> management- <mailto:genivi-ivi-layer-management-<mailto:genivi-ivi-layer-management->>
>       > bounces at lists.genivi.org<mailto:bounces at lists.genivi.org>] On Behalf Of mukesh singh
>       > Sent: Montag, 27. Februar 2017 08:51
>       > To: genivi-ivi-layer-management at lists.genivi.org<mailto:genivi-ivi-layer-management at lists.genivi.org> <mailto:genivi-ivi-<mailto:genivi-ivi->
> layer-management at lists.genivi.org<mailto:layer-management at lists.genivi.org>>
>       > Subject: Re: Please help me to get ilm_SUCCESS on ilm_init()
>       >
>       > Hi All,
>       > when I run weston command to launch QEMU, below error is
> observed
>       > which
>       > might be causing the ilm_init() fail.
>       >
>       >    - libEGL warning: DRI2: failed to open swrast (search paths
> /usr/lib/dri)
>       >    - failed to initialize display
>       >    - EGL error state: EGL_NOT_INITIALIZED
>       >
>       > Regards,
>       > Mukesh
>       >
>       >
>       > On Fri, Feb 24, 2017 at 7:57 PM, mukesh singh
> <hellopinkusingh at gmail.com<mailto:hellopinkusingh at gmail.com>>
>       > wrote:
>       >
>       > > Hi all,
>       > > I have written an application for taking screenshot using ilm
> library.
>       > >
>       > > ilm_init() is failing.    and     ivi-controller not available
>       > >
>       > > During launching weston, I observed below error:
>       > >
>       > > libEGL warning: DRI2: failed to open swrast (search path
> /usr/lib/dri)
>       > > failed to initialized display
>       > > EGL error state: EGL_NOT_INITIALIZED
>       > > Failed to initialize GL renderer; failing back to pixman.
>       > >
>       > >
>       > > Regards,
>       > > Mukesh
>       > >
>       > _______________________________________________
>       > genivi-ivi-layer-management mailing list
>       > genivi-ivi-layer-management at lists.genivi.org<mailto:genivi-ivi-layer-management at lists.genivi.org> <mailto:genivi-ivi-<mailto:genivi-ivi->
> layer-management at lists.genivi.org<mailto:layer-management at lists.genivi.org>>
>       > http://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-
> management <http://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-
> management>
>
>



More information about the genivi-ivi-layer-management mailing list