Please help me to get ilm_SUCCESS on ilm_init()

mukesh singh hellopinkusingh at gmail.com
Sat Mar 4 10:26:11 EST 2017


Hi All,
I am now running weston on ubuntu without any error.
But still ilm_init() is failing.
Enabled WAYLAND_DEBUG and got the below log.

[658557.526]  -> wl_display at 1.get_registry(new id wl_registry at 2)
[658557.599]  -> wl_display at 1.sync(new id wl_callback at 3)
[658557.800] wl_display at 1.delete_id(3)
[658557.830] wl_registry at 2.global(1, "wl_compositor", 4)
[658557.870] wl_registry at 2.global(2, "wl_subcompositor", 1)
[658557.908] wl_registry at 2.global(3, "wp_viewporter", 1)
[658557.939] wl_registry at 2.global(4, "wp_presentation", 1)
[658557.969] wl_registry at 2.global(5, "zwp_relative_pointer_manager_v1", 1)
[658558.004] wl_registry at 2.global(6, "zwp_pointer_constraints_v1", 1)
[658558.038] wl_registry at 2.global(7, "wl_data_device_manager", 3)
[658558.071] wl_registry at 2.global(8, "wl_shm", 1)
[658558.105] wl_registry at 2.global(9, "wl_drm", 2)
[658558.135] wl_registry at 2.global(10, "wl_seat", 5)
[658558.166] wl_registry at 2.global(11, "zwp_linux_dmabuf_v1", 1)
[658558.201] wl_registry at 2.global(12, "wl_output", 3)
[658558.244]  -> wl_registry at 2.bind(12, "wl_output", 1, new id [unknown]@4)
[658558.289] wl_registry at 2.global(13, "zwp_input_panel_v1", 1)
[658558.320] wl_registry at 2.global(14, "zwp_input_method_v1", 1)
[658558.352] wl_registry at 2.global(15, "zwp_text_input_manager_v1", 1)
[658558.431] wl_registry at 2.global(16, "zxdg_shell_v6", 1)
[658558.450] wl_registry at 2.global(17, "xdg_shell", 1)
[658558.493] wl_registry at 2.global(18, "wl_shell", 1)
[658558.531] wl_registry at 2.global(19, "weston_desktop_shell", 1)
[658558.552] wl_registry at 2.global(20, "weston_screenshooter", 1)
[658558.576] wl_callback at 3.done(752)
[658558.596]  -> wl_display at 1.sync(new id wl_callback at 3)
[658558.702] wl_display at 1.delete_id(3)
[658558.727] wl_output at 4.geometry(0, 0, 270, 158, 0, "weston-X11", "none",
0)
[658558.807] wl_output at 4.mode(3, 1024, 600, 60000)
[658558.857] wl_callback at 3.done(752)
[658558.879]  -> wl_display at 1.sync(new id wl_callback at 3)
[658558.958] wl_display at 1.delete_id(3)
[658558.979] wl_callback at 3.done(752)
ivi_controller not available
[Warning] The ilm_control_context is already destroyed
[658559.020]  -> wl_display at 1.sync(new id wl_callback at 3)
[658559.099] wl_display at 1.delete_id(3)
[658559.120] wl_callback at 3.done(752)


Regards,
Mukesh

On Mon, Feb 27, 2017 at 1:30 PM, Ucan, Emre (ADITG/SW1) <
eucan at de.adit-jv.com> wrote:

> Hi,
>
> Your problem is nothing to do with wayland-ivi-extensions.
>
> Weston cannot find the correct gpu driver. Therefore, it fails to start.
>
> Best regards
>
> Emre Ucan
> Software Group I (ADITG/SW1)
>
> Tel. +49 5121 49 6937
> > -----Original Message-----
> > From: genivi-ivi-layer-management [mailto:genivi-ivi-layer-management-
> > bounces at lists.genivi.org] On Behalf Of mukesh singh
> > Sent: Montag, 27. Februar 2017 08:51
> > To: genivi-ivi-layer-management at lists.genivi.org
> > Subject: Re: Please help me to get ilm_SUCCESS on ilm_init()
> >
> > Hi All,
> > when I run weston command to launch QEMU, below error is observed
> > which
> > might be causing the ilm_init() fail.
> >
> >    - libEGL warning: DRI2: failed to open swrast (search paths
> /usr/lib/dri)
> >    - failed to initialize display
> >    - EGL error state: EGL_NOT_INITIALIZED
> >
> > Regards,
> > Mukesh
> >
> >
> > On Fri, Feb 24, 2017 at 7:57 PM, mukesh singh <hellopinkusingh at gmail.com
> >
> > wrote:
> >
> > > Hi all,
> > > I have written an application for taking screenshot using ilm library.
> > >
> > > ilm_init() is failing.    and     ivi-controller not available
> > >
> > > During launching weston, I observed below error:
> > >
> > > libEGL warning: DRI2: failed to open swrast (search path /usr/lib/dri)
> > > failed to initialized display
> > > EGL error state: EGL_NOT_INITIALIZED
> > > Failed to initialize GL renderer; failing back to pixman.
> > >
> > >
> > > Regards,
> > > Mukesh
> > >
> > _______________________________________________
> > genivi-ivi-layer-management mailing list
> > genivi-ivi-layer-management at lists.genivi.org
> > http://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management
>



More information about the genivi-ivi-layer-management mailing list