Please help me to get ilm_SUCCESS on ilm_init()

Ucan, Emre (ADITG/SW1) eucan at de.adit-jv.com
Mon Feb 27 03:00:09 EST 2017


Hi,

Your problem is nothing to do with wayland-ivi-extensions.

Weston cannot find the correct gpu driver. Therefore, it fails to start.

Best regards

Emre Ucan
Software Group I (ADITG/SW1)

Tel. +49 5121 49 6937
> -----Original Message-----
> From: genivi-ivi-layer-management [mailto:genivi-ivi-layer-management-
> bounces at lists.genivi.org] On Behalf Of mukesh singh
> Sent: Montag, 27. Februar 2017 08:51
> To: genivi-ivi-layer-management at lists.genivi.org
> Subject: Re: Please help me to get ilm_SUCCESS on ilm_init()
> 
> Hi All,
> when I run weston command to launch QEMU, below error is observed
> which
> might be causing the ilm_init() fail.
> 
>    - libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/dri)
>    - failed to initialize display
>    - EGL error state: EGL_NOT_INITIALIZED
> 
> Regards,
> Mukesh
> 
> 
> On Fri, Feb 24, 2017 at 7:57 PM, mukesh singh <hellopinkusingh at gmail.com>
> wrote:
> 
> > Hi all,
> > I have written an application for taking screenshot using ilm library.
> >
> > ilm_init() is failing.    and     ivi-controller not available
> >
> > During launching weston, I observed below error:
> >
> > libEGL warning: DRI2: failed to open swrast (search path /usr/lib/dri)
> > failed to initialized display
> > EGL error state: EGL_NOT_INITIALIZED
> > Failed to initialize GL renderer; failing back to pixman.
> >
> >
> > Regards,
> > Mukesh
> >
> _______________________________________________
> genivi-ivi-layer-management mailing list
> genivi-ivi-layer-management at lists.genivi.org
> http://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management


More information about the genivi-ivi-layer-management mailing list