cmake is failing while building wayland-ivi-extention

mukesh singh hellopinkusingh at gmail.com
Sat Feb 4 12:26:49 EST 2017


Hi All,
cmake is failing for me while building wayland-ivi-extention.
Error message:
> -- checking for module 'wayland-server>=1.11.0'
>
> -- package 'wayland-server>=1.11.0' not found

Regards,
Mukesh

On Thu, Feb 2, 2017 at 5:46 PM, mukesh singh <hellopinkusingh at gmail.com>
wrote:

> Hi Eugen,
> My weston version is 1.3.0
> And I have cloned wayland from
>
> http://git.projects.genivi.org/wayland-ivi-extension.git
>
> Regards,
> Mukesh
>
> On Thu, Feb 2, 2017 at 5:23 PM, Friedrich, Eugen (ADITG/SW1) <
> efriedrich at de.adit-jv.com> wrote:
>
>> Hi Mukesh,
>>
>> Most probably you have to also version of Weston in you Linux repository.
>>
>> Please check this?
>>
>> Best regards
>>
>> Eugen Friedrich
>> Software Group I (ADITG/SW1)
>>
>> Tel. +49 5121 49 6921
>>
>> > -----Original Message-----
>> > From: genivi-ivi-layer-management [mailto:genivi-ivi-layer-management-
>> > bounces at lists.genivi.org] On Behalf Of mukesh singh
>> > Sent: Donnerstag, 2. Februar 2017 12:07
>> > To: genivi-ivi-layer-management at lists.genivi.org
>> > Subject:
>> >
>> > Hi All,
>> > I am trying to build wayland-ivi-extension.
>> > I am following README at https://github.com/GENIVI/wayl
>> and-ivi-extension
>> >
>> > getting below error while executing command  cmake ..
>> >
>> > -- checking for module 'wayland-server>=1.11.0'
>> >
>> > -- package 'wayland-server>=1.11.0' not found
>> >
>> > CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:283
>> > (message):
>> >
>> > A required package was not found
>> >
>> > Call Stack (most recent call first):
>> >
>> > /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:337
>> > (_pkg_check_modules_internal)
>> >
>> > protocol/CMakeLists.txt:26 (pkg_check_modules)
>> >
>> > -- checking for module 'wayland-server>=1.11.0'
>> >
>> > -- package 'wayland-server>=1.11.0' not found
>> >
>> > CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:283
>> > (message):
>> >
>> > A required package was not found
>> >
>> > Call Stack (most recent call first):
>> >
>> > /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:337
>> > (_pkg_check_modules_internal)
>> >
>> > weston-ivi-shell/CMakeLists.txt:26 (pkg_check_modules)
>> >
>> > -- checking for module 'weston>=1.11.0'
>> >
>> > -- package 'weston>=1.11.0' not found
>> >
>> > CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:283
>> > (message):
>> >
>> > A required package was not found
>> >
>> > Call Stack (most recent call first):
>> >
>> > /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:337
>> > (_pkg_check_modules_internal)
>> >
>> > weston-ivi-shell/CMakeLists.txt:27 (pkg_check_modules)
>> >
>> > -- gtest_INCLUDE_DIRS: gtest_INCLUDE_DIRS-NOTFOUND
>> >
>> > -- gtest_LIBRARIES:
>> >
>> > -- gtest not found, disabling unit tests (BUILD_ILM_API_TESTS=OFF)
>> >
>> > -- Configuring incomplete, errors occurred!
>> >
>> > See also
>> > "/home/msingh/geniviComponent/waylandIviExtn/wayland-ivi-
>> > extension/build-ivi-extn/CMakeFiles/CMakeOutput.log".
>> >
>> >
>> > See also
>> > "/home/msingh/geniviComponent/waylandIviExtn/wayland-ivi-
>> > extension/build-ivi-extn/CMakeFiles/CMakeError.log".
>> >
>> >
>> > Please help in building.
>> >
>> > Some More info:
>> >
>> > 1. Weston is installed.
>> >
>> > sudo apt-get build-dep wayland weston
>> >
>> > 2. Getting below message for sudo apt-get build-dep wayland weston
>> > wayland-protocols
>> >
>> > E: Unable to find a source package for wayland-protocols
>> > Regards,
>> > Mukesh
>> > _______________________________________________
>> > genivi-ivi-layer-management mailing list
>> > genivi-ivi-layer-management at lists.genivi.org
>> > http://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management
>>
>
>



More information about the genivi-ivi-layer-management mailing list