How can I run a Qt applicaton on ivi-shell?

zhangyang zhangyang-0206 at 163.com
Wed Dec 6 04:34:06 EST 2017


Hi yang:
1. If you want your qt application run with ivi-shell, you should export QT_WAYLAND_SHELL_INTEGRATION=ivi-shell first.

2. I don't know your qt version, if it is >= 5.7,  you can set QT_IVI_SURFACE_ID to specify ivi-surface-id for your qt app. follows this:

https://codereview.qt-project.org/#/c/121297/
else if it is <5.7, you should apply genivi-ivi patch here:   https://github.com/GENIVI/genivi-dev-platform/tree/master/meta-genivi-dev/meta-qt5


3. Be sure your ubuntu already have genivi-ivi-extension support



good luck!





At 2017-12-06 09:30:09, "Yang Zhonghua" <happy2discover at gmail.com> wrote:
>Hi guys,
>
>I am new to wayland.
>
>[situation]
>The ivi-shell demo could run correctly on Ubuntu 17.10 so far.
>
>[goal]
>1. I made a hello-world Qt Quick2 application and tried to make it managed
>by ivi-shell.
>2. Two fullscreen applications could run on diffrent layers at the same
>time. The bottom one could show directly when the top one exits.
>
>[problem]
>I copied weston.ini in ivi-shell folder and added the following lines.
>
>[ivi-launcher]
>workspace-id=3
>icon-id=4010
>icon=/home/ubuntu/Downloads/weston/data/icon_ivi_hello-world-qt-quick2.png
>path=/home/ubuntu/Projects/hello-world-qt-quick2/hello-world-qt-quick2
>
>
>But the hello-world Qt Quick2 application couldn't run on ivi-shell.
>AFAIK, the Qt application should make a request to generate surface-id.
>Anybody knows how to do it? Thanks so much!
>
>I've been stuck for almost one month...
>_______________________________________________
>genivi-ivi-layer-management mailing list
>genivi-ivi-layer-management at lists.genivi.org
>https://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management


More information about the genivi-ivi-layer-management mailing list