IVI-Surface-ID not working

张洋 zhangyang-0206 at 163.com
Mon Dec 4 05:25:09 EST 2017


Hi genivi-ivi-layer team:
        I make qt program based on qt5.7.1. However, set "IVI-Surface-ID" to qquickview is not working. I found the qt patch here:
https://github.com/GENIVI/genivi-dev-platform/tree/master/meta-genivi-dev/meta-qt5
but this patch is for qt 5.6.3 or lower qt version.  However, I tried apply this patch manually, and got this problem:

In file included from /root/qualcomm/adp/msm8996au-lv-0-1_hlos_dev.git/apps_proc/poky/build/tmp-glibc/work/8x96auto-agl-linux/qtwayland/5.7.1+gitAUTOINC+4b23163fb6-r0/git/src/client/qwaylanddisplay.cpp:53:0:
/root/qualcomm/adp/msm8996au-lv-0-1_hlos_dev.git/apps_proc/poky/build/tmp-glibc/work/8x96auto-agl-linux/qtwayland/5.7.1+gitAUTOINC+4b23163fb6-r0/git/src/client/qwaylandivishell_p.h:50:60: fatal error: QtWaylandClient/private/qwaylandclientexport_p.h: No such file or directory

In file included from /root/qualcomm/adp/msm8996au-lv-0-1_hlos_dev.git/apps_proc/poky/build/tmp-glibc/work/8x96auto-agl-linux/qtwayland/5.7.1+gitAUTOINC+4b23163fb6-r0/git/src/client/qwaylandwindow.cpp:50:0:
/root/qualcomm/adp/msm8996au-lv-0-1_hlos_dev.git/apps_proc/poky/build/tmp-glibc/work/8x96auto-agl-linux/qtwayland/5.7.1+gitAUTOINC+4b23163fb6-r0/git/src/client/qwaylandivisurface_p.h:50:60: fatal error: QtWaylandClient/private/qwaylandclientexport_p.h: No such file or directory

The file qwaylandclientexport_p.h seems has been removed in qt5.7.1.  I tried replace it with some similar h file but got more build errors.  Could you please help make a patch on qt5.7.1, thank you!

Best Regards!
Zhang, yang 
Yanfeng Visteon Electronics Technology (Shanghai) Co. Ltd.
1001 North Qinzhou Road Shanghai China 200233
Phone: +86 17717427053




More information about the genivi-ivi-layer-management mailing list