Issue of wayland-ivi-extension quick-start guide

Natsume, Wataru (ADITJ/SWG) wnatsume at jp.adit-jv.com
Tue May 31 01:09:55 EDT 2016


Hello Lee-san,

Let me update the guide at new wiki page.
Thank you for the information.

https://at.projects.genivi.org/wiki/display/WIE/Wayland+IVI+Extension+Home

Best Regards,
Wataru Natsume

Best Regards,
Wataru Natsume

---
Wataru Natsume / 夏目 亘
Advanced Driver Information Technology
Software Group (ADITJ/SWG)
E-mail: wnatsume at jp.adit-jv.com<mailto:wnatsume at jp.adit-jv.com>
Tel: +81-(0)566-61-4551 / Extension 551-43644

From: genivi-ivi-layer-management-bounces at lists.genivi.org [mailto:genivi-ivi-layer-management-bounces at lists.genivi.org] On Behalf Of ???
Sent: Friday, May 27, 2016 9:36 AM
To: genivi-ivi-layer-management at lists.genivi.org
Subject: Issue of wayland-ivi-extension quick-start guide

Hello

Below is fixed script for wayland-ivi-extension quick-start guide
I received help from fredcadete in IRC #automotive
It verified in my board. I can see sample navigation application now (EGLWLMockNavigation)

Please update like below to quick-start guide
--------------------------------------------
EGLWLMockNavigation &
LayerManagerControl create layer 1000 600 400
LayerManagerControl set layer 1000 render order 10
LayerManagerControl set surface 10 source region 0 0 600 400
LayerManagerControl set surface 10 destination region 0 0 600 400
LayerManagerControl set screen 0 render order 1000
LayerManagerControl set layer 1000 visibility 1
LayerManagerControl set surface 10 visibility 1
--------------------------------------------

Thank you
From: 이양우 [mailto:YangWoo.lee at hyundai-autron.com]
Sent: Thursday, May 26, 2016 2:59 PM
To: 'genivi-ivi-layer-management at genivi.org'
Subject: Issue of wayland-ivi-extension quick-start guide


Hello
I'm going through the ivi extension quick start guide, and I have trouble running the example
http://projects.genivi.org/wayland-ivi-extension/quick-start

Below is my work sequence with weston.ini according to quick start guide
Please help me if I missed something.
Thank you

----------------------------------------------------------------------------
[core]
#backend=fbdev-backend.so
shell=ivi-shell.so

[ivi-shell]
ivi-module=ivi-controller.so
#ivi-shell-user-interface=/usr/lib/weston/weston-ivi-shell-user-interface
-------------------------------------------------------------------------------
$ mkdir –p /var/run/user/1000
$ export XDG_RUNTIME_DIR=/var/run/user/1000
$ weston &
$ EGLWLMockNavigation &
$ LayerManagerControl create layer 1000 600 400
$ LayerManagerControl set layer 1000 render order 10
$ LayerManagerControl set screen 0 render order 1000
$ LayerManagerControl set layer 1000 visibility 1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.genivi.org/pipermail/genivi-ivi-layer-management_lists.genivi.org/attachments/20160531/c1f7440f/attachment.html>


More information about the genivi-ivi-layer-management mailing list