Touch input behavior on overlapping ivi surfaces

Vikas Patil vikasmpatil at gmail.com
Tue May 24 08:59:52 EDT 2016


Dear All,

Here (attached here the image ) the touch input is not going to surface 1
even after touching any of the two buttons on surface 1.  Instead touch
event goes to surface 2. Also if I touch anywhere in the area marked green
also goes to surface 2 even it being the part of surface 1. Touching on the
rest of the light blue area delivers touch correctly to surface 1.

Both the surfaces are on one layer only (e.g. layer id 1000)

Any one here faced such issue? What could be going wrong here? Any
suggestions/ideas?

Also try the limiting the input acceptance area using wayland region. But
it didn't work.

            input_region = wl_compositor_create_region(wlCompositor);

            wl_region_add(input_region, 728, 5, 72, 144);

            wl_surface_set_input_region(surface, input_region);

I am on weston 1.8, wayland-ivi-extension 1.4.0 and qt/qtwayland 5.5.1.




​Thanks & Regards,
Vikash
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.genivi.org/pipermail/genivi-ivi-layer-management_lists.genivi.org/attachments/20160524/41919f16/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: issue1.png
Type: image/png
Size: 35453 bytes
Desc: not available
URL: <http://lists.genivi.org/pipermail/genivi-ivi-layer-management_lists.genivi.org/attachments/20160524/41919f16/attachment.png>


More information about the genivi-ivi-layer-management mailing list