Race condition when building wayland-ivi-extension 1.9.0

Joh, Yong-Il (Tolkien) Yong-Il.Joh at windriver.com
Fri Mar 18 06:36:43 EDT 2016


Hi Cadete.

I applied your patch, and confirmed that the build of wayland-ivi-extension is ok.

to Pedro

could you apply a patch, and check the result?

thank you.

__
Yong-iL Joh, Sr.MTS, Wind River 

-----Original Message-----
From: Frederico Cadete [mailto:frederico.cadete at awtce.be] 
Sent: Friday, March 18, 2016 1:12 AM
To: Joh, Yong-Il (Tolkien); pedro.alvarez at codethink.co.uk; genivi-ivi-layer-management at lists.genivi.org
Cc: Joh, Yong-Il (Tolkien); Pedro Alvarez; genivi-ivi-layer-management at lists.genivi.org; genivi-projects at lists.genivi.org; James Thomas
Subject: Re: Race condition when building wayland-ivi-extension 1.9.0

On Thu, Mar 17, 2016 at 10:57:32PM +0900, Changhyeok Bae wrote:
...
> 2016-03-17 22:20 GMT+09:00 Joh, Yong-Il (Tolkien) 
> <Yong-Il.Joh at windriver.com
> >:
> 
> > Hi Changhyeok
> >
> >
> >
> > In my personal opinion,
> >
> > this issue should be resolved by author, not integrator.

Let's help the author then :)

Could the wayland-ivi-extension maintainers consider including the attached patch? I have tested compilation and basic runnning, but I must say I don't have the full environment (Weston) for v1.9 so I was not able to run the test suite.

> >
> >
> >
> > anyway, it’s better to add your workaround to meta-ivi L-1.0 release.

Please consider including the attached patch in meta-ivi/baserock if you need this fix sooner.

I hope it helps!

Best regards,
Frederico

Frederico Cadete
R&D Software Engineer
VIT Software Development
-------------------------------------------------
AWTC Europe - www.aweurope.eu - www.aisin-aw.co.jp

> >
> > if any concern, please reply this email.
> >
> >
> >
> > thank you.
> >
> >
> >
> > *__*
> >
> > *Yong-iL Joh**, *Sr.MTS, *Wind River*
> >
> >
> >
> > *From:* Changhyeok Bae [mailto:changhyeok.bae at gmail.com]
> > *Sent:* Tuesday, March 15, 2016 10:21 PM
> > *To:* Pedro Alvarez
> > *Cc:* Friedrich, Eugen (ADITG/SW1); Joh, Yong-Il (Tolkien); James 
> > Thomas; genivi-projects at lists.genivi.org; 
> > genivi-ivi-layer-management at lists.genivi.org
> > *Subject:* Re: Race condition when building wayland-ivi-extension 
> > 1.9.0
> >
> >
> >
> > Hi
> >
> >
> >
> > I attached in case of me for raspberrypi2 build.
> >
> > My build server has 32 Core. If it's race condition, the temporary 
> > resolution is to add PARALLEL_MAKE = "" in wayland-ivi-extension.bb.
> >
> >
> >
> > 2016-03-15 19:13 GMT+09:00 Pedro Alvarez <pedro.alvarez at codethink.co.uk>:
> >
> > Hi,
> >
> > attached build logs of a successful and a failed build of 
> > wayland-ivi-extension. My guess from looking at the logs is that it 
> > tries to build one of the examples (simple-ivi-share) before one of 
> > the dependencies is available, but this is just a guess..
> >
> > Thanks for helping with this!
> > Pedro
> >
> >
> > On 15/03/16 07:20, Friedrich, Eugen (ADITG/SW1) wrote:
> > > Hi all,
> > >
> > > We building this components twice a day and did not saw this issue 
> > > so
> > far.
> > > There might be some difference In the set up.
> > >  @Pedro: could you send the configure log and compiler log from
> > succesfull and failing build from your machine.
> > >
> > > Best regards
> > >
> > > Eugen Friedrich
> > > Software Group I (ADITG/SW1)
> > >
> > > Tel. +49 5121 49 6921
> > >> -----Original Message-----
> > >> From: genivi-projects-bounces at lists.genivi.org 
> > >> [mailto:genivi-projects- bounces at lists.genivi.org] On Behalf Of 
> > >> Joh, Yong-Il (Tolkien)
> > >> Sent: Dienstag, 15. März 2016 06:36
> > >> To: Pedro Alvarez; James Thomas; genivi-projects at lists.genivi.org
> > >> Subject: RE: Race condition when building wayland-ivi-extension 
> > >> 1.9.0
> > >>
> > >> Hi
> > >>
> > >> could you give the configure/compile log of wayland-ivi-extension?
> > >> It did not appeared in my build environment.
> > >>
> > >> thank you.
> > >>
> > >> __
> > >> Yong-iL Joh, Sr.MTS, Wind River
> > >>
> > >>
> > >> -----Original Message-----
> > >> From: genivi-projects-bounces at lists.genivi.org 
> > >> [mailto:genivi-projects- bounces at lists.genivi.org] On Behalf Of 
> > >> Pedro Alvarez
> > >> Sent: Monday, March 14, 2016 8:01 PM
> > >> To: James Thomas; genivi-projects at lists.genivi.org
> > >> Subject: Re: Race condition when building wayland-ivi-extension 
> > >> 1.9.0
> > >>
> > >> On 01/03/16 10:10, James Thomas wrote:
> > >>> On 01/03/16 09:51, Pedro Alvarez wrote:
> > >>>> Is this a known bug? Is there a better place to report it? Has 
> > >>>> anybody else found it?
> > >>>
> > >>> genivi-ivi-layer-management at lists.genivi.org
> > >>>
> > >>
> > >> I reported the error here, but still haven't heard anything back. 
> > >> This
> > problem
> > >> is still happening and quite frequently.
> > >>
> > >> Regards,
> > >> Pedro
> >
> >
> > _______________________________________________
> > genivi-ivi-layer-management mailing list 
> > genivi-ivi-layer-management at lists.genivi.org
> > https://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-managemen
> > t
> >
> >
> >

> _______________________________________________
> genivi-ivi-layer-management mailing list 
> genivi-ivi-layer-management at lists.genivi.org
> https://lists.genivi.org/mailman/listinfo/genivi-ivi-layer-management



More information about the genivi-ivi-layer-management mailing list